Which Linux Kernels Do The Different Versions of NI-VXI for Linux Support?

Updated Apr 20, 2018

Reported In

Driver

  • NI-VXI

Operating System

  • Linux

Issue Details

Which Linux Kernels do the different versions of NI-VXI for Linux support?

Solution

The following table shows what kernel is supported under each version and, if relevant, what versions of RedHat are supported:
 
 
NI-VXI Driver VersionLinux Kernel SupportedSupported Linux Distributions
1.6.12.2.xRed Hat 5.x and 6.x
1.6.22.2.xRed Hat 5.x and 6.x
1.6.32.4.x and 2.2.xRed Hat 6.x and 7.x
1.6.42.4.x and 2.2.xRed Hat 6.x and 7.x
2.0.02.4.xRed Hat 7.1, 7.2, 7.3
2.0.12.4.2+Red Hat 7.1, 7.2, 7.3, 8.0, 9
2.1.02.6.15*Red Hat Enterprise Linux 4
Suse Linux 9.2, 9.3
Mandrake 10.0, 10.1


Note: The difference between 1.6.3 and 1.6.4 is that 1.6.4 supports the VXI-770, 870B controllers, and PCI-MXI-2 Universal.

NI-VXI 2.1.0 for Linux also includes versions 2.0.1 and 1.6.4 of the driver, providing support for prior versions of Linux.

Please contact your sales representative to upgrade or obtain the NI-VXI driver for Linux. 

*Note: For this driver, minor revisions (0.0.x revisions) are free releases, while major revisions (x.0.0 or 0.x.0 revisions) are paid releases.

WAS THIS ARTICLE HELPFUL?

Not Helpful